SoftRAID and macOS 12 Monterey

SoftRAID 6 Pro, Lite and XT work with macOS 10.12 or later and Windows 10. M1 Macs require macOS 11.3 and later.

Our software team is constantly testing and working to optimize and improve SoftRAID, as well as keep up with changes in the computing world. Stay up to date on what the team is working on and also subscribe to our Critical Updates email to stay on top of all SoftRAID news.