30-Day Free Trial!

How to use a SoftRAID startup volume with High Sierra

If you're using High Sierra, and booting up from a SoftRAID volume, you'll need to follow the steps given in this forum post, since the macOS High Sierra Installer does not recognize SoftRAID volumes as valid startup volumes.

RAID 5 Validation failed
#1
I have a 12TB RAID5 array (4x 4TB), I recently received an alert that one of my drives had a failure predicted, I ran verify on it and it said it had an i/o error. I have the extra disk ready to replace, but I ran a validate of the array first and the validate failed. I am not sure what where to proceed from here.

Here is the most recent log

May 16 16:22:47 - SoftRAID Driver: The volume "OWC_RAID" (disk7) has started validating.
May 16 17:12:05 - SoftRAID Driver: The volume "OWC_RAID" (disk7) failed to validate because one the disks encountered a read error. The disk (disk5, SoftRAID ID: 068EB46989A7A580) was unable to read sectors (offset 1356588908544, i/o block size 3145728, error E00002E7). This disk should be replaced.
May 16 17:12:10 - SoftRAID Driver: A disk for the volume "OWC_RAID" (disk7) encountered a read error (E00002E7). The disk (disk3, SoftRAID ID: 068EB46989D2B500) was unable to read sectors. The error occurred at volume offset 1356588908544 (i/o block size 3145728). This disk should be replaced.

“disk5” does not appear to have errors from here yet it failed the validation in the log. (see attached)


I am concerned with replacing one disk and having the whole drive fail while reassembling the area.


Attached Files Thumbnail(s)
   
Reply
#2
Certainly the disk has had an error and the disk is showing many sectors that may need to be reallocated because they cannot be read.

You need to be certain your backup is up to date.

Then I would arrange for a new disk.

In the meantime, "certify" the disk with errors. This will cause your volume to not have any redundancy, so be sure your backups stay current.

Either the disk will start to reallocate the bad sectors during the certify, or will "fix" them. If the disk reallocates sectors, you know to replace it. If the disk passes certification and the error flag in SoftRAID about 100+ unreliable sectors goes away, then perhaps this was caused by a brownout or something and your disk might be OK. But be cautious and if it shows any additional signs of problem, get rid of it.

To replace the disk, insert a freshly "certified" disk, initialize it with SoftRAID, then "add disk". it will rebuild. To increase rebuild speed, set optimization to server or workstation.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)