30-Day Free Trial!

How to use a SoftRAID startup volume with High Sierra

If you're using High Sierra, and booting up from a SoftRAID volume, you'll need to follow the steps given in this forum post, since the macOS High Sierra Installer does not recognize SoftRAID volumes as valid startup volumes.

Progress indicator for Rebuild?
#1
I have gone through the steps to replace a bad drive, and SoftRaid (5.6.5) is saying that my volume is rebuilding, but it's not giving any indication of how long for the rebuild to complete.

I watched this video (skipped to the relevant timestamp): [url]https://www.youtube.com/watch?v=vgwoEIbNEA8&t=309s[/url], and it says that I will get a countdown timer telling me how long before the volume is rebuilt.

Am I missing something, or is this just a (slightly) out-of-date video?

Super-helpful video otherwise!

Thanks in advance!
Reply
#2
The volume must be mounted read/write to rebuild.

Perhaps the volume is not mounted?

If you cannot get the volume to mount normally, try Disk Warrior.
Reply
#3
The volume was mounted, but only in read-only.

I have tried unmounting and re-mounting, but now the volume is saying that it's "waiting for mount" in the volume tile in SoftRaid. See screenshot.

What next? Reboot the machine?


Attached Files Thumbnail(s)
   
Reply
#4
A little more info: I tried using diskwarrior to mount the volume, but it won't mount. Gives error code 4902.

As an aside, while it is attempting to mount, RaidSoft appears to be rebuilding, because the 'offset' increments during the mount attempt.

After the mount fails, the offset stops incrementing again.

Thanks for any help you can give!
Reply
#5
There is some kind of problem with the volume.

restart and run Disk Warrior again. Startup from a "clean" system if necessary.

Until the volume can cleanly mount, the rebuild will not progress.
Reply
#6
Still won't mount, except in read-only mode.

When you say 'clean' startup, what do you mean, exactly?

Any other ideas?
Reply
#7
If the volume mounts as "read only" by OS X, it is very surprising that Disk Warrior cannot rebuild the directory.

Outside of doing a backup/erase/restore, contact Alsoft support, they may understand what is going on.
Reply
#8
Oh, I didn't realize that you thought I should rebuild the directory with DiskWarrior...

Here is what I tried with DiskWarrior: After unmounting the read-only volume, I tried mounting it from within DiskWarrior (also tried to mount from SoftRaid). It wouldn't mount. I got error 4902 from DiskWarrior.

I am currently re-backing up all my files from the volume, in case I need to completely rebuild it. As soon as that is complete, I will attempt a rebuild of the directory in diskWarrior. If that works, and I can mount read-write, I will expect the SoftRAID rebuild to start again.

If any of these steps are wrong, please let me know.
Reply
#9
that is correctly done!

Good luck!

Sometimes it takes a couple tries with Disk Warrior, or a different startup volume but when a volume can mount (even read only), it is rare if Disk Warrior cannot repair it.

Once the volume is OK, the rebuild will proceed.
Reply
#10
I think I'm in a chicken-and-egg situation here. I can't fix the directory on the volume with DiskWarrior, unless I start 'clean' which I take to mean boot from the DW recovery partition on the DW thumb drive.

The problem with doing that, is that the thumb drive doesn't have the SoftRAID drivers installed, so DW doesn't see the volume, etc.

If I'm missing something, please let me know.

Otherwise, I need to remove the old volume and recreate it from scratch. Sigh...
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)