Hello There, Guest! Register

macOS Sierra boot volume issues
#1
Hi -

I have a Mac Pro 5.1 (mid-1010) running macOS Sierra 12.12.3. It's a dual 2.93 GHz with 48 Gb of RAM. It has four 250 Gb Samsung EVO 850 in the drive bays and a fifth one in the lower optical drive bay. I'm using that computer for movies editing and SFX (Blackmagic DaVinci Resolve + Fusion 8). I'm running a licensed full version of SoftRAID 5.5.5. There's a RAID 4 volume on these five SSD, where user's home directories are located. I also have an OWC Accelsior S PCIe board with another 250 Gb Samsung EVO 850 which is my boot drive. No RAID on that one, but SoftRAID's driver is installed and the volume is protected against deletion.

In order to get better read performance, I want to replace that PCIe board and its single standalone SSD by an Addonics Quad mSATA PCIe SSD board, with four 240 Gb Kingston mS200 SSD, bonded in a RAID 1+0 volume, to be used as boot drive and scratch space.

So, I created the RAID 1+0 volume and as wanted a fresh system install on it, I prepared a bootable USB key with macOS Sierra 12.12.3.

By habit, I reset the NVRAM and SMC, then booted on the USB key and started the operating system install. Near the end, the install failed with a message saying that it couldn't rebuild the cache in the target volume. I tried twice with the same failure.

Then, I restarted the Mac Pro on the original standalone SSD and launched the install from there. Once the initial install files were copied, I had to reboot the computer to complete the install. Apparently, the Mac didn't find the new RAID 1+0 volume and it restarted on the standalone SSD. That RAID 1+0 volume didn't mount even after macOS restarted.

I started the SoftRAID utility. Everything seemed to be fine, but when I tried to mount the volume, it didn't work. I didn't even get an error message. Then, I found out that when I started the macOS Disk Utility (which take more than a minute to display the disks), the RAID 1+0 volume did mount automatically !

Then, as my very last resort option, I cloned the standalone boot SSD to the mounted RAID 1+0 volume, using Carbon Copy Cloner 4.1.13, and restaured the boot cache using SoftRAID before restarting the Mac on that volume. It worked !!!

I've been using SoftRAID for quite a while and very happy with it, but now I'm somehow worried and thus I have a couple of questions :

- Is the system reliable as is ?

- What if I wish to reinstall from scratch the operating system on RAID 1+0 boot volume ? I guess that I would face the same cache rebuilding problem.

- Why the RAID 1+0 volume can't be automatically mounted with the SoftRAID utility when not used as boot drive ? Why just by launching Apple's disk utility the volume is mounted ?

- One more thing : when I start the SoftRAID utility (with an administrator account), it asks me the password. As suggested in another thread, I reinstalled the driver but that didn't change anything.

Any help or advice would be greatly appreciated !

Thanks !
Reply
#2
I am not certain what happened, it would take guesswork. Perhaps there is a limitation (i.e. bug) in the Sierra installer, where it cannot set the boot cache on the Addonics card. (it may require a driver that is not installed in the first pass of the Mac OS installation, for example)

Ultimately you found the correct solution, which is to use Carbon Copy Cloner (or SuperDuper) to clone a valid system onto the RAID 1+0 volume.

To answer your questions:
Yes your system should be reliable as is.

If you have to do a clean install, yes you may face the same issue. Avoid this by installing onto another disk/volume, then cloning it. its a pain, but the Apple boot cache technology is limited and can be buggy.

I do not know the experience you had with the volume not mounting until you ran DU. Something else must have been going on, as the OS X driver does not touch SoftRAID partitioned disks. It could have been coincidence, or else I would have to guess. Its an odd behavior.

reinstalling the driver would not have made a difference. One thing you could have tried is "rebuild boot cache" with SoftRAID from a different Sierra boot volume. it may or may not have helped.

As a side note: That is a lot of disks/power consumption in that Mac Pro. We have seen users that have such a situation where disks in the bays stop showing up on restart. If you run into any similar behavior, replace the power supply. I don't know how the symptom would show up with SSD, rather than HDD, but keep this in mind if you get problems down the road.
Reply
#3
Hi -

Thanks for your reply.

It doesn't make me feel much better, but at least there are workarounds available. I guess that I will keep an external drive with macOS and SoftRAID already set, just in case I have to reinstall the system.

Regarding the consumption issue, I would be surprised that nine latest generation SSD would draw much more power than four hard drives and an optical drive engineered almost a decade ago.
Reply
#4
Re: Power consumption: It may be a slightly different issue than just power, but we have seen this enough to make note of it. Its clearly an issue where OS X no longer recognizes the disks until a power down cycle.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)