30-Day Free Trial!

How to use a SoftRAID startup volume with High Sierra

If you're using High Sierra, and booting up from a SoftRAID volume, you'll need to follow the steps given in this forum post, since the macOS High Sierra Installer does not recognize SoftRAID volumes as valid startup volumes.

Hello There, Guest! Register
cant remove disks from raid 10
#1
Background: I had tried to create a RAID 10 across two older Lacie "2big" (two drive) enclosures, but I kept getting error messages. I then decided to keep them as two separate volumes and use the second enclosure as a backup destination for the first and run a backup job daily to get them in sync. This works well for my intended use.

So it's all working except I cannot remove the "unused" disks from the RAID 10. Whenever I start up I get this message:

Jul 18 07:20:45 - SoftRAID Driver: The SoftRAID volume "Backup Volume1" is missing one or more disks. It has been mounted but will not offer the normal level of data protection.

It works fine of course but when I would use the menu option to "Remove Missing Disks" nothing happens, there's no entry in the Softraid log and the disks are not removed and I get the same error message.

Is there a way I can remove the missing disks successfully?
Reply
#2
I think you are Just seeing the counters.

Try "remove missing secondary disk". This will reset the counters on the volume and may be all you need to do.
Let me kno if this does not work.
Reply
#3
Thanks, but I can't find "remove missing secondary disk" on the menu. (I've attached my menu screenshot).
Reply
#4
Select the volume, it is in the volumes menu. (if a Mirror volume is not selected it is "remove missing disks".)
Reply
#5
Rehash: Originally tried to mirror an existing RAID 0 volume (call it vol 1) with a second RAID 0 volume (call it vol 2) to create a RAID 1+0 volume. Each volume resides in an older Lacie 2Big enclosure with two physcal drives. The first volume was (and is fine) datawise.

I could not get the RAID 1+0 to work (various error messages) and I chalked that up to having two old enclosures. So I decided to use the second enclosure as a standalone volume 2 and take snapshop backups from the first volume using vol2 as a destination. That works fine.

But vol 1 is still not letting me remove the missing disks. I've attached a video to show you what I see.
Reply
#6
Just send a SoftRAID tech support file to support @ softraid.com

I can look and figure out what is going on. Pictures and videos are not so helpful.
Reply
#7
I did investigate this.

We do not allow you do convert a RAID 1+0 with two missing disks to a stripe. (We should, but do not)

When you use the command "remove missing disks", it disassociates them from the RAID 1+0 volume, so they will not rebuild when attached again. But there is no way to change the state of the volume from "missing 2 disks".

So you need to live with the missing disks warning message until you have the time to delete the volume and restore from backup.

A Mirror volume, we allow "remove missing secondary disks" and also to have a Mirror with no secondary disks. We do not have that flexibility with RAID 1+0 volumes.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)