30-Day Free Trial!

How to use a SoftRAID startup volume with Catalina

If you're using Catalina, and have a T2 Security chip on your Mac, then Catalina (10.15) requires SIP to be disabled first. Read this thread for more information.

Hello There, Guest! Register
Unstable SoftRAID on Initialization
#1
Hello SoftRAID Community,

Using SoftRAID is a great idea. I was skeptical, but with OWC's backing, I thought "maybe...it will work"

After reading the QuickStart, I did the recommended step of certifying disks.
There have been two attempts, both of which failed

As you can imagine, this does not inspire confidence in the product over simple JBOD volumes and a good backup strategy. I was ready to purchase SoftRAID and now I'm having second thoughts

Any guidance is appreciated.
Let me know if I can grab logs that help narrow down the error.



Hardware:
Model Name: Mac mini
Model Identifier: Macmini6,1
Processor Name: Intel Core i5
Processor Speed: 2.5 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 3 MB
Hyper-Threading Technology: Enabled
Memory: 16 GB
Boot ROM Version: 278.0.0.0.0
SMC Version (system): 2.7f1

Enclosure:
OWC Mercury Elite Pro Quad (using USB 2, Type A)

Drives:
Seagate IronWolf NAS Drives, 8TB

Attempt 1:
- I tried to certify uninitialized disks C and D (3 passes) in the enclosure simultaneously. This failed. See first screenshot
Attempt 2:
- Thinking the USB bus was overly saturated and perhaps that was causing issues, I lowered to one disk certification and used 2 passes as a "good enough" but this still failed


Attached Files Thumbnail(s)
       
Reply
#2
This is not a disk error. What is happening is the SoftRAID "Monitor" is losing contact with the Application. This was introduced by (we believe) a security update that somehow blocks the communication. SoftRAID puts up an error because without being able to talk to the disks, it needs to be relaunched.

We are working on this issue, but there are no clues in the OS or logs, so it has been challenging to figure this out.

If this is happening to you, a simple workaround is use the terminal to certify the disks. (certify does not use the SoftRAID driver in any case, it is a low level script which writes a pattern to disk, then reads it back.

the command is:

softraidtool disk disk2 certify 3

SoftRAIDtool is our command line tool
Disk means you are using a disk command
Disk2 is the number of the disk, as in the disks column
Certify is the command you are applying
3 is the number of passes.

(you can do two (or more) at once by opening a second terminal window, also)

softraidtool help has help on all the command line options.

The application does not need to be open to do this, so you can get your disks certified.

thanks and we apologize for the inconvenience.
Reply
#3
Thank you for the detailed help, I can confirm that:
- the CLI worked without issues for one disk, working on #2
- The CLI seemed *significantly* faster than the GUI + Monitor. Almost 2x as fast as the quoted time from the GUI
I will post back with final results of the evaluation

For other thread readers that may not be as familiar with OS X / macOS, you can find the disk id for the command above by running:
diskutil list
and unmount with command:
diskutil unmountDisk [Disk ID goes here]
Reply
#4
The process is identical, as both SoftRAID and the terminal are running the same tool, which is a command line script.

thanks!

SoftRAID also shows the disk# in the disk tiles.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)