30-Day Free Trial!

How to use a SoftRAID startup volume with Catalina

If you're using Catalina, and have a T2 Security chip on your Mac, then Catalina (10.15) requires SIP to be disabled first. Read this thread for more information.

Hello There, Guest! Register
Display soft raid status in menu bar not showing
#1
Softraid lite 5.7.2 is running and the preference box for status in menu bar is ticked but s not showing.
Reply
#2
We have corresponded "off line", but I do not know at this time. The most likely explanation is the SoftRAID Monitor is crashing.

Conclusion:
The problem was resolved by using "Reinstall SoftRAID Driver from the volumes menu.
Reply
#3
Just updated to Lite 5.7.3 as had the same problem in 5.7.2 and still have the problem - & re-install driver option is 'greyed out'.
Reply
#4
You must select the system volume you are reinstalling the driver into. Drivers are inside a system, not on disks.

See if that helps.
Reply
#5
(01-11-2019, 01:06 PM)SoftRAID Support Wrote: You must select the system volume you are reinstalling the driver into. Drivers are inside a system, not on disks.

See if that helps.

Yes did this - during upgrade & separately just now & restarted - no change, not showing
Reply
#6
Then the Monitor is being blocked.

Lets try this next:
"uninstall SoftRAID" from utilities menu. (this will wipe your license and preferences)
restart
Download a fresh copy of SoftRAID
Run it and let it install the driver.

Does the Monitor work now?

Are you running any anti-virus apps? What about any "clean up" utilities?
Reply
#7
Do I need to back-up my volumes/data before trying this or will it pick them up ok after a reinstall?
Reply
#8
When you uninstall the SoftRAID driver, SoftRAID volumes will not mount, but when you run SoftRAID again, they will mount normally
Reply
#9
So have done the uninstall / install cycle a couple of times & different ways - assuming it was correct as serial no: went etc. No change , no status in menu bar
Apps that you asked about AV = Sophos Home (9.7.7) - Malwarebytes (3.6.21) & AppCleaner (3.5)
Reply
#10
Note: The Monitor icon will display even with an invalid serial number.

Try temporarily disabling (uninstalling) the three apps you listed. Then get a fresh copy of SoftRAID and install again.

The SoftRAID Monitor is a basic tool, it should always be functional.
Send us a SoftRAID support file to support at softraid. Maybe we can see if Monitor is crashing.

The only other thing I can think of is a quarantine issue, which 5.7.x should prevent.

Run the Terminal.app
Enter xattr into a terminal window.
Then a "Space".
Then find the SoftRAID application and drag and drop it into the terminal window. This will add a path.
Hit Enter.
The total command will look something like this if you have SoftRAID XT:
xattr /Applications/SoftRAID\ XT\ 5.7.3/SoftRAID\ XT\ 5.7.3.app

If the response from this is: "com.apple.quarantine". Then you know this app got quarantined by Gatekeeper. If there is no return, then it is not under quarantine.

Now, test to see if the SoftRAID driver is under quarantine:

sudo xattr /Library/Extensions/SoftRAID.kext
Hit Enter.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)