30-Day Free Trial!

How to use a SoftRAID startup volume with High Sierra

If you're using High Sierra, and booting up from a SoftRAID volume, you'll need to follow the steps given in this forum post, since the macOS High Sierra Installer does not recognize SoftRAID volumes as valid startup volumes.

Hello There, Guest! Register
Cannot Resize after Drive Change
#1
I have a newly purchased Thunderbay 4 with SoftRAID XT. I added 4 drives to the enclosure (8TB, 8TB, 3TB and 6TB 7200 Seagate drives) and set up as two RAID5 volumes, one at 3TB, one at 6TB. I know that the 3TB drive would severely limit the space available, but that was the only drive I had so I could offload my data from a failing Drobo RAID setup. Once I transferred all the footage, I replaced the 3TB drive with an 8TB (making my drives 3x8TB and 1x6TB). I estimated that that would increase my drive space from 12TB to 24TB (minus the space used from the RAID5 setup). However, when I try to resize either volume, the max size is still limited to 3TB and 6TB, same as before. I have restarted the drive and my computer. I am on the newest versions of SoftRAID XT and OSX Mojave. What can I do here?

A second question is regarding speed. I was expecting write speeds of around 500MB/sec read, but appear to only be getting 300MB/sec max. All 4 drives are in good working condition, I have no other external drives connected (I do have a monitor connected to the RAID, and when I disconnect it, it appears to hover around 360MB/sec, but thunderbolt 3 should have plenty of bandwidth to support both, right? Read speeds are as expected. Is there a way that I can diagnose this?
Reply
#2
To increase the capacity of a volume, the free space must be both contiguous and at the end of the disks. You probably will need to backup volume 2, delete it, resize volume 1, then create volume 2 to get around this.

Performance is limited only by the drives for reads and with a fast CPU, same. If you have a slower CPU, then write performance will be slower, but not reads.

If you have a freshly erased volume, you should get 500MB/sec on reasonable drives. I recently saw 600MB/s on 5TB Toshiba drives in testing.

I suspect you have data on the volumes, which will slow such benchmarking testing.
Reply
#3
I ran a speedtest right after setting up the raid, with no data on it. I have a Macbook Pro 2018 with an i9 and nothing else connected to the Thunderbolt ports, besides power. All drives are 7200RPM in good condition. Is there a way to figure out where the bottleneck may be? And is there a reason why I am noticing a speed drop when I have a monitor connected to the RAID?
Thanks,
Brandon
Reply
#4
The Monitor is consuming some bandwidth. I have never benchmarked that, might be a fun idea.

I very recently did a "blog" writeup that will be posted soon, where I took the Toshiba 5TB and moved them from internal to a thunderbay on a Mac Mini 2018 and got 600MBs. That is what you should expect.

for reads, there is an easy test. "verify" each drive with Activity Monitor running. In the disk column, you can see the throughput. Make sure each drive is at least 150MB/s, if not faster. Then you know your target for read speeds. (Newer drives will get up to 200MB/s.)
Reply
#5
So I have performed some tests to hopefully diagnose the speed issue. I replaced the single 6TB drive with an 8TB (so 4x8TB). I initialized all 4 drives, and formatted each into a separate volume. I then speed tested each drive, getting 215MB/sec Read/Write on 3 Seagate Ironwolf drives, and 180MB/sec on a Seagate Barracuda drive. So it seems as though they should have plenty of speed. I then formatted all 4 into a single 24TB volume RAID5 HFS+ Journaled. With no other drives or monitors attached, I am now getting about 400MB/sec WRITE and 570MB/sec READ. (Although the speed does seem to fluctuate quite a bit, from about 330 to 420). While that is better than what I was getting before, it is still far off from 500MB/sec write speed. For reference, with a 4K monitor attached to the drive, I lose another 100MB/sec (Disappointing, as I was hoping to free a port on my machine).
I have a 2018 i9 MacBook Pro, so CPU shouldn't be an issue. I am also able to get close to 600MB/sec on a different drive attached to the same thunderbolt port.
Any suggestions?
Thanks,
Brandon
Reply
#6
This thread is now about performance. I am attaching a recent result obtained with 5TB Toshiba drives in a OWC Thunderbay 3 enclosure, connected to a 2018 Mac Mini 2018.

This is what you should expect.

Any limitation here is hardware, as SoftRAID's driver will go as fast as the CPU and drives will allow. You are correct the CPU should be plenty fast. So it must be the drives, cable or enclosure. The Iron Wolf are very fast, the Barracuda less so.

The Thunderbay 4/3 you have is the same enclosure I just produced the bottom result with.

Be sure you have a good cable. Note that shorter cables are faster than longer ones with Thunderbolt 3. (but with just drives, I can't imagine it making a difference.

Outside of this, I do not know why you are getting reduced performance on your disks.


Attached Files Thumbnail(s)
   
Reply
#7
Thank you very much for your help. One final question for you.
Is it normal to see so much fluctuation when testing speed? With no applications running and nothing else connected to the thunderbolt ports, the drive will go from 400MB/sec to 200MB/sec, then up to 300, back down, etc. Each test round can vary wildly. None of my other drives do this, they will keep a steady rate. Did you see any of this when you were testing your Thunderbay 4?
Thank you again,
Brandon
Reply
#8
Chances are your volume may be indexing. Depending on the test, yes you can get 10% fluctuations or so, but not 30% unless there is activity on the volume or disks. There should be consistency. that is why benchmarks are most consistent with empty volumes.
Reply
#9
After some work trying to figure out this issue, I believe I have found the problem. The single Seagate Barracuda drive running at 180MB/sec vs the other 3 Ironwolf drives running at 230MB/sec. Replacing this drive with one that matched the speed of the others has completely fixed the speed fluctuations. I am now getting a constant 450MB/sec Write and 650MB/sec Read.
Not sure if this is a firmware/software issue or just a Raid5 thing, but problem solved.
Thanks,
Brandon
Reply
#10
Faster hardware often fixes performance issues!

One of the possible issues is the Barracuda taking longer to reply means the Iron Wolf drives are "waiting" too often.

Glad you are sorted out!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)