30-Day Free Trial!

How to install the SoftRAID driver with macOS Catalina (10.5.1)

If you're using Catalina, and have a T2 Security chip on your Mac, then Catalina (10.15) requires Startup System Security to be disabled (set to none). Read this thread for more information.Read this thread for more information.

Hello There, Guest! Register
Problem updating SoftRAID driver with new iMac Pro
(01-12-2018, 01:55 PM)SoftRAID Support Wrote: Not yet. We are working on getting an iMac Pro in, as we have been unable to figure this out remotely.

Apple has ignored our bug report so far.

Hopefully we can find a workaround soon. I have a list of users with this problem that I will notify as soon as we find something. if you have an iMac Pro, email to support and we can add you to the list until we can figure this out.

Another affected iMac Pro user here, looking forward to a fix
So are we!

We are expecting to receive an iMac Pro Friday the 19th January, or Monday the 22.
Setting the new Secure Boot setting to No Security seems to have fixed it for me: https://support.apple.com/en-us/HT208330
I will mention this to other users. not ideal, but a good start.
(01-21-2018, 07:33 PM)Rob Wrote: Setting the new Secure Boot setting to No Security seems to have fixed it for me: https://support.apple.com/en-us/HT208330

Same here, I can now boot my iMac Pro with my Thunderbay connected, and when I run the Softraid app it doesn't give me an endless cycle of prompts to update the driver.

I should also mention, the kernel panics/restarts I was occasionally getting all mentioned BridgeOS in the crash log, and it seems there's many iMac Pro users who are experiencing the same thing - https://discussions.apple.com/thread/8236615

People are wondering whether it's related to the use of Thunderbolt 3 to Thunderbolt 2 adapters, but the mention of BridgeOS in the crash log probably means these restarts might also be related to the Secure Boot feature.
Thanks for confirming, I notified all the users who have complained.

We will post and also notify users independently when we find a more permanent solution.

Thanks for the link on the iMac Pro restart problem.
I've just confirmed that setting the new Secure Boot setting to 'No Security' works around the SoftRaid reboot loop for me as well.
Here are some Step by step instructions on setting the Security level for your iMac Pro:

1) Boot into Recovery Mode.
Restart your iMac Pro, press and hold Command (⌘)-R immediately, until after you see the Apple logo, when you can release the keys. This will boot the machine into macOS Recovery Mode.

2) Select Utilities in the menu bar in the Utilities window.

3) Select Startup Security Utility in the Utilities window.

4) Enter your Admin Password.
When asked to authenticate, click Enter macOS Password, then select an administrator account and enter its password.

5) Select "No Security".

Startup Security Utility will present three Secure Boot settings:

Full Security—The default setting that brings the highest level of security. An active Internet connection may be required at software installation time so that your iMac Pro can confirm that it’s booting up a macOS or Windows version that hasn’t been tampered with in any way. Leave this setting enabled to run a macOS or Windows version that’s currently installed on your iMac Pro, or any cryptographically signed operating system trusted by Apple.

Medium Security—This setting verifies the macOS or Windows version on the startup disk only to see if it’s been properly signed by Apple or Microsoft, but doesn’t require an Internet connection or updated integrity information from Apple. It does not prevent the machine from running an operating system that’s no longer trusted by Apple. Use this setting to boot into older versions of macOS regardless of Apple’s level of trust.

No Security—This is the lowest security setting which doesn’t enforce any security requirements for the bootable operating system on your startup disk. Use it to boot into Linux or any other operating system supported on your hardware, no signing or verification with Apple required. This is the way all other Macs currently start up.

6) Restart your machine normally.

7) Run the current version of SoftRAID, select your boot volume, and "reinstall SoftRAID driver" from the volumes menu. This will solve this issue completely and macOS will now load the current SoftRAID driver at startup.
Down-grading security worked for me as well. Not ideal, but workable.

(01-22-2018, 08:05 AM)SoftRAID Support Wrote: I will mention this to other users. not ideal, but a good start.
I currently have 2 Thunderbay IV Raid 5 units connected to my MacBookPro. I am running high Sierra and under the about menu is says I am running version 5.6.4 with driver 5.6.4.

Only one of the volumes appears on the desktop after a reboot. I started soft raid and everything appears ok but the volume not showing on the desktop shows it is "unmounted". I try to mount the volume and it shows "mounting" for about 10 seconds then disappears and the volume still shows as "unmounted".

The volume I can't get to mount had been connected to a MacMini used with time machine backup. When I recently tried to upgrade the MacMini from Sierra to High Sierra all the issues documented here surfaced.

I got errors with time machine backup saying it couldn't back because it couldn't create a folder (or something like that).

Any ideas on what I could do to get the volume mounted?

Forum Jump:

Users browsing this thread: 1 Guest(s)