30-Day Free Trial!

How to use a SoftRAID startup volume with High Sierra

If you're using High Sierra, and booting up from a SoftRAID volume, you'll need to follow the steps given in this forum post, since the macOS High Sierra Installer does not recognize SoftRAID volumes as valid startup volumes.

Hello There, Guest! Register
Problem updating SoftRAID driver with new iMac Pro
#11
iMac Pro experiencing kernel panics while SoftRaid volumes attached. Tried deleting all system files with "softraid" in the name and reinstalling. First installation timed out. Second time it seemed to work but I had 2 SoftRaid icons in the toolbar, and after attaching 2 of my SoftRaid volumes the system froze and restarted. This doesn't happen without SoftRaid volumes attached, nor with same volumes attached to MacBook Pro running High Sierra.

Waiting for software fix or suggestions.
Reply
#12
I have not had any reports of kernel panics, so this is an unrelated problem to the driver install issue.

Send us a tech support file to support at softraid so we can investigate.
Reply
#13
BTW: SoftRAID can run, but the 5.6.2 (bundled, and limited) driver is loading, which means your volumes can mount, but will not report errors or rebuild. So it is a serious issue, but at least your data is available.
Reply
#14
I'm not seeing any kernel panics, but I am also seeing the issue reported in the first post of this thread on my iMacPro with a ThunderBay enclosure attached and SoftRAID v5.6.3..

Curious if this is at all related to the new kernel extension blocking security feature enabled in High Sierra...

Apple Technical Note TN2459 User-Approved Kernel Extension Loading
Reply
#15
FYI, I have been able to install v5.6.3 with my ThunderBay drives detached, reboot, startup SoftRAID v5.63, then reattach the ThunderBay drives and they show up in the SoftRAID for ThunderBay app and I can monitor the drives.

I was also able to quit the SoftRAID application and restart it. It didn't attempt to reinstall the drivers. Seem like this workaround worked for me....
Reply
#16
Thanks for the feedback. We have had other users do your trick, then after a restart, the 5.6.2 driver re-appears. it is a strange issue.
Reply
#17
I've just confirmed that after a reboot, starting up the SoftRAID application once again tries to install the driver. Looks like the workaround is only good until a reboot.
Reply
#18
It seems that way.

Somehow, OS X "finds" the old driver and reloads it. That is what makes this so strange.
Reply
#19
Any news on a fix? I got my iMac Pro two weeks ago and have been checking the SoftRAID webpage daily since then hoping for a solution to update my SoftRAID driver. I'm having the same trouble as everyone else here; it makes me scared to use my Thunderbay 4.

Thanks!


Attached Files Thumbnail(s)
   
Reply
#20
Not yet. We are working on getting an iMac Pro in, as we have been unable to figure this out remotely.

Apple has ignored our bug report so far.

Hopefully we can find a workaround soon. I have a list of users with this problem that I will notify as soon as we find something. if you have an iMac Pro, email to support and we can add you to the list until we can figure this out.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)