How Can We Help?

Can I keep using SoftRAID 5 or SoftRAID 6?

SoftRAID 6 is not compatible with Ventura, you will need SoftRAID 7. SoftRAID 6 will still work on older versions of macOS.

SoftRAID 5 does not support Big Sur or later.

close
open