1. Home
  2. Docs
  3. SoftRAID – Quick Start and Install Guide
  4. Installation for macOS
  5. Preparing Your Mac for SoftRAID Installation

Preparing Your Mac for SoftRAID Installation

SoftRAID 6 works with macOS 10.12 or later. Apple silicon Macs require macOS 11.3 and later. SoftRAID XT is only for select OWC storage solutions. For both OWC and third-party enclosure support, you will need SoftRAID Pro or Lite.

There is no installer for SoftRAID.

The SoftRAID application acts as an installer the first time you run it. The SoftRAID application will install (or upgrade) the SoftRAID driver, SoftRAID Monitor, and all other SoftRAID files the first time you run it.

Each time you download a new version of the SoftRAID application and run it, the application will upgrade all the SoftRAID files.

If you ever want to uninstall SoftRAID, just select Uninstall SoftRAID from the Utilities menu. The SoftRAID application will then remove the SoftRAID driver, SoftRAID Monitor, and all of the other SoftRAID files.

Preparing your Mac for SoftRAID installation:

If you have a Mac with an Apple T2 Security Chip running macOS 10.15 “Catalina” or Apple silicon,

  • List of Macs with Apple silicon
  • List of Macs Apple T2 Security Chip
  • If you are installing on a Mac with an Apple T2 Security Chip running macOS 10.15 “Catalina” or Apple silicon Mac additional steps are needed.

    Additional Steps for Additional Steps for Apple silicon Macs
    Additional Steps for Apple T2 Security Chip Macs

    If your Mac does not have an Apple T2 Security Chip or Apple silicon, skip ahead to the “Completing SoftRAID Installation” section.

    Was this article helpful to you? Yes No 1